通达信公式教程 通达信自用卖点主图指标公式

时间:2019/7/30 4:11:00来源:网络整理编辑:相关标签:
分享按钮

通达信公式教程 通达信自用卖点主图指标公式 南方财富网小编为您提供

MA5:MA(CLOSE,5);

MA10:MA(CLOSE,10);

MA20:MA(CLOSE,20);

MA60:MA(CLOSE,60);

MA120:MA(CLOSE,120);

MA250:MA(CLOSE,250);

DRAWICON(CROSS(MA10,MA5),MA10,2); {5日下穿10日做记号};

DRAWICON(CROSS(MA60,MA5),MA60,2); {5日下穿60日做记号};

A1:=MAX(MAX(MA(C,5),MA(C,10)),MA(C,20));

A2:=MIN(MIN(MA(C,5),MA(C,10)),MA(C,20));

①:=(C<O AND O>A1 AND C<A2) OR (C<O AND REF(O,1)>A1 AND C<A2);

DRAWTEXT(①,MA(C,20),'断头刀'),COLORGREEN;

②:=(C<O AND O>A1 AND L<A2) OR (C<O AND REF(O,1)>A1 AND L<A2);

DRAWTEXT(②,L,'R断头刀'),COLORGREEN;

DRAWTEXT(H>REF(O,3)*1.19,H,'小心'),COLORGREEN;

DRAWTEXT(H>REF(O,3)*1.32,H,'▲小心'),COLORGREEN;

DRAWTEXT(H>REF(O,3)*1.36,H,'绝对小心'),COLORGREEN;

DRAWTEXT(H/MAX(O,C)>1.03,C,'▲小心'),COLORGREEN;

PDAY1 := BARSLAST(CROSS(MA60,MA5));{5日均线下穿60日均线}

PDAY2 := BARSLAST(CROSS(MA60,MA10));{10日均线下穿60日均线,至此形成鸭颈部}

PDAY3 := BARSLAST(LOW=LLV(LOW,PDAY2));{形成头部,要反弹}

PDAY4 := BARSLAST(CROSS(MA5,MA10));{反弹后,5日均线和10日均线金叉}

PDAY5 := BARSLAST(CROSS(MA10,MA5));{反弹不久,5日均线和10日均线形成死叉,形成嘴部}

DGLYT1:= PDAY1>PDAY2 AND PDAY2>PDAY3 AND PDAY3>PDAY4 AND PDAY4>PDAY5 AND PDAY5<5;

DGLYT2:= COUNT(CROSS(MA10,MA5),PDAY2)=1;

DGLYT:=DGLYT1 AND DGLYT2;

DRAWTEXT(DGLYT,H,'倒挂LYT'),COLORGREEN;

MA30:=MA(C,30);

TSJ:=COUNT(CROSS(MA20,MA5),21)=1 AND COUNT(CROSS(MA30,MA5),21)>0 AND

COUNT(CROSS(MA20,MA10),21)>0 AND COUNT(CROSS(MA30,MA10),21)>0;

MM1:=MA(V,5);

MM2:=MA(V,10);

MM3:=MA(V,20);

MM4:=MA(V,30);

DXJ:=COUNT(CROSS(MM3,MM1),21)=1 AND COUNT(CROSS(MM4,MM1),21)>0 AND

COUNT(CROSS(MM3,MM2),21)>0 AND COUNT(CROSS(MM4,MM2),21)>0;

ZTJ:=COUNT(TSJ,13)>0 AND COUNT(DXJ,13)>0;

TSJDSJ:=ZTJ AND (REF(BARSLAST(ZTJ),1)>20 OR BARSSINCE( ZTJ)=0);

DRAWTEXT(TSJDSJ,H,'#'),COLORGREEN;

TY:=C;

AA1:=REF(TY,10)=HHV(TY,2*10+1); B1:=FILTER(AA1,10); C1:=BACKSET(B1,10+1); HD:=FILTER(C1,10);

AA2:=REF(TY,10)=LLV(TY,2*10+1); B2:=FILTER(AA2,10); C2:=BACKSET(B2,10+1); LD:=FILTER(C2,10);

前期高位:REF(C,BARSLAST(HD)),COLOR00FF00,POINTDOT;

STICKLINE(C,前期高位,前期高位,8,0),COLORYELLOW;

前期低位:REF(C,BARSLAST(LD)),COLOR00FF00,POINTDOT;

STICKLINE(C,前期低位,前期低位,8,0),COLORYELLOW;

绝对量顶天立地:=V>REF(HHV(V,60),1) OR V>REF(HHV(V,120),1);{绝对量顶天立地};

DRAWTEXT(绝对量顶天立地 AND O>C AND C<REF(C,1),C,'L顶天卖'),COLORGREEN;

更多股票公式相关资讯请关注南方财富网

评论 0条评论

期待你的神评论~
剩余200

全部评论(0

    还没有评论,快来抢沙发~

    点击加载更多

    删除操作

    确认删除此条评论?
    删除
    取消